We have completed our investigation in coordination with our carriers and confirmed that the root cause has been fully addressed. Delivery rates have been confirmed as normal over the past 24 hours.
Between approximately 6:00 AM and 7:30 AM AEST on 15th March 2026, a carrier-side issue resulted in an elevated number of message failures for a subset of customers during that window. A small number of accounts were affected; those customers have been contacted directly with further details.
Posted Mar 16, 2026 - 07:56 AEST
Update
We are continuing to monitor delivery rates, while investigating cases of unexpected failures with carriers.
Posted Mar 15, 2026 - 13:16 AEST
Monitoring
Delivery rates have returned to normal, we are continuing to investigate with our carriers
Posted Mar 15, 2026 - 08:04 AEST
Investigating
We are have detected message delivery failure rates higher than normal. We are working with network carriers to investigate.