Cloudflare is reporting that the incident is resolved.
Posted Nov 19, 2025 - 01:18 AEST
Update
A content delivery network (Cloudflare) we leverage for some auxiliary services is currently experiencing a widespread outage. Cloudflare is aware of, and investigating the issue. Dashboard & API are unaffected but some components (such as export downloads) are impacted. Cloudflare status is available here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 22:36 AEST
Update
A content delivery network (Cloudflare) we leverage for some auxiliary services is currently experiencing a widespread outage. Cloudflare is aware of, and investigating the issue. Dashboard & API are unaffected but some components (such as export downloads) are impacted. Cloudflare status is available here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 22:21 AEST
Identified
A content delivery network (Cloudflare) we leverage for some auxiliary services is currently experiencing a widespread outage. Cloudflare is aware of, and investigating the issue. Dashboard & API are unaffected but some components (such as export downloads) are impacted. Cloudflare status is available here: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 22:17 AEST
This incident affected: Dashboard & API and Cloudflare Sydney, NSW, Australia - (SYD).